aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index d85aef0..a02e991 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,7 +1,13 @@
+
target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ main.cpp
+ Particle.cpp
+ ParticleEmitter.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
ComponentManager.cpp
Component.cpp
GameObject.cpp
@@ -16,6 +22,10 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ ParticleEmitter.hpp
+ ParticleSystem.hpp
+ Particle.hpp
+ SDLApp.hpp
ComponentManager.h
ComponentManager.hpp
Component.h