aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt25
1 files changed, 12 insertions, 13 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 245df31..1b4b1c2 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -3,35 +3,34 @@ target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
- #Particle.cpp
- #ParticleEmitter.cpp
- #ParticleSystem.cpp
- SdlContext.cpp
+ Particle.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
ComponentManager.cpp
Component.cpp
ScriptSystem.cpp
+ PhysicsSystem.cpp
+ CollisionSystem.cpp
+ Collider.cpp
+ SdlContext.cpp
+
RenderSystem.cpp
- #PhysicsSystem.cpp
- #Force.cpp
- #CollisionSystem.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
- #ParticleEmitter.h
- #ParticleSystem.h
- #Particle.h
SdlContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
System.h
ScriptSystem.h
- #PhysicsSystem.h
- #Force.h
- #CollisionSystem.h
+ PhysicsSystem.h
+ CollisionSystem.h
+ Collider.h
+ SdlContext.h
RenderSystem.h
)