aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt34
1 files changed, 32 insertions, 2 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 392b7d7..d85aef0 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,3 +1,33 @@
-target_sources(main PUBLIC
- main.cpp
+target_sources(crepe PUBLIC
+ Asset.cpp
+ Sound.cpp
+ SoundContext.cpp
+ ComponentManager.cpp
+ Component.cpp
+ GameObject.cpp
+ Collider.cpp
+ Rigidbody.cpp
+ Sprite.cpp
+ ScriptSystem.cpp
+ Script.cpp
)
+
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ Asset.h
+ Sound.h
+ SoundContext.h
+ ComponentManager.h
+ ComponentManager.hpp
+ Component.h
+ GameObject.h
+ GameObject.hpp
+ Collider.h
+ Rigidbody.h
+ Sprite.h
+ System.h
+ ScriptSystem.h
+)
+
+add_subdirectory(api)
+add_subdirectory(util)
+