aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 8323490..cce25c4 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,7 +1,12 @@
+
target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ Particle.cpp
+ ParticleEmitter.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
ComponentManager.cpp
Component.cpp
GameObject.cpp
@@ -9,12 +14,21 @@ target_sources(crepe PUBLIC
Rigidbody.cpp
Sprite.cpp
ScriptSystem.cpp
+ Script.cpp
+ PhysicsSystem.cpp
+ Transform.cpp
+ Force.cpp
+ CollisionSystem.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ ParticleEmitter.h
+ ParticleSystem.h
+ Particle.h
+ SDLApp.h
ComponentManager.h
ComponentManager.hpp
Component.h
@@ -25,6 +39,10 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Sprite.h
System.h
ScriptSystem.h
+ PhysicsSystem.h
+ Transform.h
+ Force.h
+ CollisionSystem.h
)
add_subdirectory(api)