aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cc71435..232d330 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -15,13 +15,22 @@ project(crepe C CXX)
add_library(crepe SHARED)
target_include_directories(crepe
- SYSTEM INTERFACE .
+ PUBLIC SYSTEM INTERFACE .
)
-# NOTE: all libraries *must* be linked as PRIVATE
+# TODO: libraries should be linked as PRIVATE
target_link_libraries(crepe
- PRIVATE soloud
+ PUBLIC soloud
)
add_subdirectory(crepe)
+install(
+ TARGETS crepe
+ FILE_SET HEADERS DESTINATION include/crepe
+)
+
+
+add_executable(dummy_audio dummy_audio.cpp)
+target_link_libraries(dummy_audio PUBLIC crepe)
+