aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index fffe6d3..892e8fc 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -8,13 +8,11 @@ set(CMAKE_BUILD_TYPE Debug)
project(game C CXX)
add_subdirectory(../src crepe)
-add_executable(main
- background/AquariumSubScene.cpp
- background/BackgroundSubScene.cpp
- background/ForestParallaxScript.cpp
- background/ForestSubScene.cpp
+
+add_executable(main)
+
+target_sources(main PUBLIC
GameScene.cpp
- background/HallwaySubScene.cpp
MoveCameraManualyScript.cpp
player/PlayerScript.cpp
player/PlayerSubScene.cpp
@@ -45,5 +43,9 @@ add_executable(main
hud/SpeedScript.cpp
)
+add_subdirectory(background)
+add_subdirectory(prefab)
+
target_link_libraries(main PUBLIC crepe)
+target_include_directories(main PRIVATE .)