aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index f81850d..497b880 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -7,7 +7,10 @@ set(CMAKE_BUILD_TYPE Debug)
project(game C CXX)
add_subdirectory(../src crepe)
-add_executable(main
+
+add_executable(main)
+
+target_sources(main PUBLIC
background/AquariumSubScene.cpp
background/AquariumScript.cpp
background/BackgroundSubScene.cpp
@@ -57,5 +60,9 @@ add_executable(main
Random.cpp
)
+add_subdirectory(background)
+add_subdirectory(prefab)
+
target_link_libraries(main PUBLIC crepe)
+target_include_directories(main PRIVATE .)