aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt28
1 files changed, 27 insertions, 1 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index dc55523..5365fb4 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -8,7 +8,8 @@ set(CMAKE_BUILD_TYPE Debug)
project(game C CXX)
add_subdirectory(../src crepe)
-add_executable(main
+
+set(SOURCES
AquariumSubScene.cpp
BackgroundSubScene.cpp
ForestParallaxScript.cpp
@@ -21,7 +22,32 @@ add_executable(main
StartGameScript.cpp
StartSubScene.cpp
main.cpp
+ mainmenu/ButtonScript.cpp
+ mainmenu/ButtonSubScene.cpp
+ mainmenu/MainMenuScene.cpp
+ mainmenu/ButtonStartScript.cpp
+)
+
+set(HEADERS
+ AquariumSubScene.h
+ BackgroundSubScene.h
+ ForestParallaxScript.h
+ ForestSubScene.h
+ GameScene.h
+ HallwaySubScene.h
+ MoveCameraManualyScript.h
+ PlayerScript.h
+ PlayerSubScene.h
+ StartGameScript.h
+ StartSubScene.h
+ mainmenu/ButtonScript.h
+ mainmenu/ButtonSubScene.h
+ mainmenu/MainMenuScene.h
+ mainmenu/MainMenuConfig.h
+ mainmenu/ButtonStartScript.h
)
+add_executable(main ${SOURCES} ${HEADERS})
+
target_link_libraries(main PUBLIC crepe)