aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-08 13:48:01 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-08 13:48:01 +0200
commit6b7a670d60fec808e4fd1fcf3a8df2c503dcbdf4 (patch)
treeaeb947a0001088ae2caddca85062845a276ceffb /test/CMakeLists.txt
parentc6cbde11c080c994577a7ebe4b966c25870dec1f (diff)
parent515aab5ab7e3281d2d77177724aae42cffc6faae (diff)
Merge branch 'loek/cleanup' of github.com:lonkaars/crepe
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt23
1 files changed, 0 insertions, 23 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
deleted file mode 100644
index f015570..0000000
--- a/test/CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-cmake_minimum_required(VERSION 3.28)
-
-set(CMAKE_C_STANDARD 11)
-set(CMAKE_CXX_STANDARD 20)
-set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
-
-set(CMAKE_BUILD_TYPE Debug)
-
-project(test C CXX)
-
-add_subdirectory(../lib/googletest googletest)
-add_subdirectory(../src crepe)
-
-add_executable(test
- dummy.cpp
- # audio.cpp
-)
-
-target_link_libraries(test
- PRIVATE gtest_main
- PUBLIC crepe # TODO: this does not work properly
-)
-