aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-09-25 17:36:31 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-09-25 17:36:31 +0200
commitf3eeedc91a04ca0651e0fe78a2119e7e3e38e391 (patch)
treefc2265ccc90abcefbdf2eb7670eb2c30c56da300 /test/CMakeLists.txt
parentf4560e02f703f1c6f857c8e5af63fa9fc4ca6438 (diff)
WIP Audio API + facade
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 26aa460..d103b9a 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -9,13 +9,15 @@ set(CMAKE_BUILD_TYPE Debug)
project(test C CXX)
add_subdirectory(../lib/googletest googletest)
+add_subdirectory(../src crepe)
add_executable(test
dummy.cpp
+ audio.cpp
)
target_link_libraries(test
- gtest_main
- # TODO: add crepe engine
+ PRIVATE gtest_main
+ PUBLIC crepe # TODO: this does not work properly
)