aboutsummaryrefslogtreecommitdiff
path: root/src/example/CMakeLists.txt
diff options
context:
space:
mode:
authorjaroWMR <jarorutjes07@gmail.com>2024-10-10 07:06:11 +0200
committerjaroWMR <jarorutjes07@gmail.com>2024-10-10 07:06:11 +0200
commit3f22ea7e41a81d3c818bdeb536f8df7ff352ae0f (patch)
tree68fc72eb4c11beb5e1c304b9490fce7192d132f3 /src/example/CMakeLists.txt
parent97621ae53dfc3434cd97e45266bd4f4ac2ef49e1 (diff)
parent29fb4bda4872bdfe33a2416a239fb62fc0238167 (diff)
merge with master
Diffstat (limited to 'src/example/CMakeLists.txt')
-rw-r--r--src/example/CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/src/example/CMakeLists.txt b/src/example/CMakeLists.txt
index 17e995b..f66e08a 100644
--- a/src/example/CMakeLists.txt
+++ b/src/example/CMakeLists.txt
@@ -1,5 +1,20 @@
-add_executable(audio_internal EXCLUDE_FROM_ALL audio_internal.cpp)
-target_link_libraries(audio_internal PUBLIC crepe)
+# add_example(target_name [SOURCES...])
+function(add_example target_name)
+ # if SOURCES is not specified
+ if(NOT ARGV1)
+ # A .cpp file with target_name exists, and should be used
+ set(sources ${target_name}.cpp)
+ else()
+ set(sources ${ARGV})
+ endif()
+
+ add_executable(${target_name} EXCLUDE_FROM_ALL ${sources})
+ target_link_libraries(${target_name} PUBLIC crepe)
+endfunction()
+
+add_example(audio_internal)
+add_example(components_internal)
+add_example(script)
add_executable(particel EXCLUDE_FROM_ALL particel.cpp)
target_link_libraries(particel PUBLIC crepe)