aboutsummaryrefslogtreecommitdiff
path: root/src/example/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-23 13:12:18 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-23 13:12:18 +0200
commit04a040e28ade412ea5b1767bf77eed3956121973 (patch)
treedcc93a90f08300f49f82bc4612f0328ef77a4b64 /src/example/CMakeLists.txt
parent30d84ef9ad4a0010288db18294766fd4d5ed6f4a (diff)
move user-facing classes to api namespace
Diffstat (limited to 'src/example/CMakeLists.txt')
-rw-r--r--src/example/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/example/CMakeLists.txt b/src/example/CMakeLists.txt
index 6df4ce7..53f584f 100644
--- a/src/example/CMakeLists.txt
+++ b/src/example/CMakeLists.txt
@@ -1,3 +1,6 @@
+# all examples
+add_custom_target(examples)
+
# add_example(target_name [SOURCES...])
function(add_example target_name)
# if SOURCES is not specified
@@ -10,6 +13,7 @@ function(add_example target_name)
add_executable(${target_name} EXCLUDE_FROM_ALL ${sources})
target_link_libraries(${target_name} PUBLIC crepe)
+ add_dependencies(examples ${target_name})
endfunction()
add_example(audio_internal)