aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-22 15:37:00 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-22 15:37:00 +0200
commitf1857fc2d4ddec71b3f0395903f8446cf96b8d0c (patch)
treefeb0a1b4f80cb67ca9af89545ae67a2c03e2f23b /src/crepe/api/CMakeLists.txt
parentb151274f9009eb9f86e4df29ca2c75f5b01d4092 (diff)
fixed everything and can now work with new compiler, example rendering and made it work with component manager
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
index 9a02580..b046301 100644
--- a/src/crepe/api/CMakeLists.txt
+++ b/src/crepe/api/CMakeLists.txt
@@ -2,10 +2,19 @@ target_sources(crepe PUBLIC
# AudioSource.cpp
BehaviorScript.cpp
Script.cpp
+ Color.cpp
+ Texture.cpp
+ Sprite.cpp
+ Transform.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
# AudioSource.h
BehaviorScript.h
Script.h
+ Point.h
+ Transform.h
+ Color.h
+ Sprite.h
+ Texture.h
)