aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-01 19:53:56 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-01 19:53:56 +0200
commitef44da3f5e9ca533782da5e185e69e28c295d226 (patch)
treed44f4f849245f640eff874d53ab610cff2fbe53b /src/crepe/api/CMakeLists.txt
parent8e66301577551bc5b8a2e169be173e71de2f5e4e (diff)
Added resources to crepe
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
new file mode 100644
index 0000000..7b16fb1
--- /dev/null
+++ b/src/crepe/api/CMakeLists.txt
@@ -0,0 +1,17 @@
+target_sources(crepe PUBLIC
+ Image_asset.cpp
+ map_asset.cpp
+ Audio_asset.cpp
+ spritesheet.cpp
+ resource_manager.cpp
+)
+
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ resource.h
+ Image_asset.h
+ map_asset.h
+ Audio_asset.h
+ spritesheet.h
+ resource_manager.h
+)
+