aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-23 14:00:27 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-23 14:00:27 +0200
commit194c8c4af559f9ea35b2fc53103415ea1e47fb61 (patch)
tree93bc71b9978ed5df5afb993f70f051ddda91a2b6 /src/crepe/api/CMakeLists.txt
parenteaa05e7a981b0f581f5393882e4753d9294a3dba (diff)
parent04a040e28ade412ea5b1767bf77eed3956121973 (diff)
Merge branch 'master' into niels/rendering
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
index d29a771..37c194d 100644
--- a/src/crepe/api/CMakeLists.txt
+++ b/src/crepe/api/CMakeLists.txt
@@ -7,12 +7,21 @@ target_sources(crepe PUBLIC
Sprite.cpp
Transform.cpp
AssetManager.cpp
+ GameObject.cpp
+ Collider.cpp
+ Rigidbody.cpp
+ Sprite.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
# AudioSource.h
BehaviorScript.h
Script.h
+ GameObject.h
+ GameObject.hpp
+ Collider.h
+ Rigidbody.h
+ Sprite.h
Point.h
Transform.h
Color.h