aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/api/CMakeLists.txt
diff options
context:
space:
mode:
authorWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-10-23 21:15:58 +0200
committerWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-10-23 21:15:58 +0200
commitb5e83d076f356c6d01b7bbc1f033db4850356c0d (patch)
treec4b11f86c6ab1685e46fab9d674377a39e612fd7 /src/crepe/api/CMakeLists.txt
parent51c8a51b53a850265955a3e4bc45b40ad3f8c477 (diff)
parent04a040e28ade412ea5b1767bf77eed3956121973 (diff)
pull origin master
Diffstat (limited to 'src/crepe/api/CMakeLists.txt')
-rw-r--r--src/crepe/api/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/crepe/api/CMakeLists.txt b/src/crepe/api/CMakeLists.txt
new file mode 100644
index 0000000..ae92f3d
--- /dev/null
+++ b/src/crepe/api/CMakeLists.txt
@@ -0,0 +1,21 @@
+target_sources(crepe PUBLIC
+ # AudioSource.cpp
+ BehaviorScript.cpp
+ Script.cpp
+ GameObject.cpp
+ Collider.cpp
+ Rigidbody.cpp
+ Sprite.cpp
+)
+
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ # AudioSource.h
+ BehaviorScript.h
+ Script.h
+ GameObject.h
+ GameObject.hpp
+ Collider.h
+ Rigidbody.h
+ Sprite.h
+)
+