aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorjaroWMR <jarorutjes07@gmail.com>2024-10-09 19:58:30 +0200
committerjaroWMR <jarorutjes07@gmail.com>2024-10-09 19:58:30 +0200
commit2884c56b066fcafb4f0042799f8a16ea3b238d2a (patch)
tree9c30844807e8ab5f48a17773d19e5b565cb1a59d /src/crepe/CMakeLists.txt
parent5f84969c851530ebc430be2cf8e99c945ff7a4a7 (diff)
parent08d0b07c19edfe8c81dfe4e21c0d4c1ef128b628 (diff)
merge with master
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt22
1 files changed, 19 insertions, 3 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 43a3835..c7f18cd 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,9 +1,25 @@
-target_sources(main PUBLIC
- main.cpp
+
+target_sources(crepe PUBLIC
+ Asset.cpp
+ Sound.cpp
+ SoundContext.cpp
+ main.cpp
Particle.cpp
ParticleEmitter.cpp
ParticleSystem.cpp
SDLApp.cpp
)
-target_include_directories(main PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ Asset.h
+ Sound.h
+ SoundContext.h
+ ParticleEmitter.hpp
+ ParticleSystem.hpp
+ Particle.hpp
+ SDLApp.hpp
+)
+
+add_subdirectory(api)
+add_subdirectory(util)
+