aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-06 12:55:15 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-06 12:55:15 +0200
commit02d658a7ed92bacfdaed587102f0d2e5f6c5dc01 (patch)
tree1195a0a46b9ce4af470652fecd5c3a3a917c2c58 /src/crepe/CMakeLists.txt
parentb649adda67ed52c2e3bdcd5aa2cb4b9b0954cf16 (diff)
parentb5a5d9b1d4725f3001486c9bbd69263ed0918303 (diff)
Merge branch 'loek/cleanup' into loek/scripts
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 392b7d7..208ba1f 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,3 +1,15 @@
-target_sources(main PUBLIC
- main.cpp
+target_sources(crepe PUBLIC
+ Asset.cpp
+ Sound.cpp
+ SoundContext.cpp
)
+
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ Asset.h
+ Sound.h
+ SoundContext.h
+)
+
+add_subdirectory(api)
+add_subdirectory(util)
+