aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-23 15:21:56 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-23 15:21:56 +0200
commitadb7dfabec4811566308cd072e0542cd7eae8cc1 (patch)
tree669c19049121d7fa841e4e9287eceb2c71860ebb /src/crepe/CMakeLists.txt
parent194c8c4af559f9ea35b2fc53103415ea1e47fb61 (diff)
parent5445331293854aac26af2d5c6a20cedeaa819383 (diff)
Merge branch 'jaro/poc-physics' into niels/rendering
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index cc20f83..497423e 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,24 +1,39 @@
+
target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ Particle.cpp
+ ParticleEmitter.cpp
+ ParticleSystem.cpp
SdlContext.cpp
ComponentManager.cpp
Component.cpp
ScriptSystem.cpp
RenderSystem.cpp
+ PhysicsSystem.cpp
+ Transform.cpp
+ Force.cpp
+ CollisionSystem.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ ParticleEmitter.h
+ ParticleSystem.h
+ Particle.h
SdlContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
System.h
ScriptSystem.h
+ PhysicsSystem.h
+ Transform.h
+ Force.h
+ CollisionSystem.h
RenderSystem.h
)