aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-11-05 15:34:31 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-11-05 15:34:31 +0100
commit5f75bdbf3d38c94baeae52f4c4889f147ec6885e (patch)
tree5fc76975e41ae106df61a4d59559f0ab37fb52ac /src/crepe/CMakeLists.txt
parent9572c5b35de2d13dbe7f942e3ecc50d28b36e9b8 (diff)
move systems + update contributing.md
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index d938eb8..7f976db 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -3,17 +3,11 @@ target_sources(crepe PUBLIC
Sound.cpp
SoundContext.cpp
Particle.cpp
- ParticleSystem.cpp
SDLApp.cpp
ComponentManager.cpp
Component.cpp
- ScriptSystem.cpp
- PhysicsSystem.cpp
- CollisionSystem.cpp
Collider.cpp
SDLContext.cpp
-
- RenderSystem.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
@@ -24,15 +18,11 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
ComponentManager.h
ComponentManager.hpp
Component.h
- System.h
- ScriptSystem.h
- PhysicsSystem.h
- CollisionSystem.h
Collider.h
SDLContext.h
- RenderSystem.h
)
add_subdirectory(api)
add_subdirectory(util)
+add_subdirectory(system)