aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-06 15:28:12 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-06 15:28:12 +0200
commitaa8755148cbca29b584f7a146636b506070717f9 (patch)
tree275644d2f2cbf5de1c0aa82a3cb05df03ea9fff4 /src/crepe/CMakeLists.txt
parent39815f58e3842bb28e644e83111a619bd1374855 (diff)
move components to separate files
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 5840208..d7d563e 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -3,8 +3,11 @@ target_sources(crepe PUBLIC
Sound.cpp
SoundContext.cpp
ComponentManager.cpp
- Components.cpp
+ Component.cpp
GameObject.cpp
+ Collider.cpp
+ Rigidbody.cpp
+ Sprite.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
@@ -13,9 +16,12 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
SoundContext.h
ComponentManager.h
ComponentManager.hpp
- Components.h
+ Component.h
GameObject.h
GameObject.hpp
+ Collider.h
+ Rigidbody.h
+ Sprite.h
)
add_subdirectory(api)