aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-24 10:52:21 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-24 10:52:21 +0200
commit39054829fa69bcfa2b468015dc3852a2f8deac9f (patch)
treee7726d90fb3c23a15919360dd10bdf709e7e087a /src/crepe/CMakeLists.txt
parentdd9940720cde6975f79d65e08075687c47f0aec6 (diff)
parent5447ddd896eb49ea9fd9f9191a277fd1d5730aa3 (diff)
merge master into loek/config
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt24
1 files changed, 15 insertions, 9 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 8323490..d938eb8 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -2,29 +2,35 @@ target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ Particle.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
ComponentManager.cpp
Component.cpp
- GameObject.cpp
- Collider.cpp
- Rigidbody.cpp
- Sprite.cpp
ScriptSystem.cpp
+ PhysicsSystem.cpp
+ CollisionSystem.cpp
+ Collider.cpp
+ SDLContext.cpp
+
+ RenderSystem.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ SDLContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
- GameObject.h
- GameObject.hpp
- Collider.h
- Rigidbody.h
- Sprite.h
System.h
ScriptSystem.h
+ PhysicsSystem.h
+ CollisionSystem.h
+ Collider.h
+ SDLContext.h
+ RenderSystem.h
)
add_subdirectory(api)