aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-11-05 16:03:48 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-11-05 16:03:48 +0100
commitb770475741b7c33d57331f3139c55a3f237ad274 (patch)
treea0498c3aad476352f0e2fa0afded15d6cd077cb3 /src/crepe/CMakeLists.txt
parent74533e9fbcd0360950daec4dc297e48e30a8a2d0 (diff)
create facade folder
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 7f976db..8830e05 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,28 +1,21 @@
target_sources(crepe PUBLIC
Asset.cpp
- Sound.cpp
- SoundContext.cpp
Particle.cpp
- SDLApp.cpp
ComponentManager.cpp
Component.cpp
Collider.cpp
- SDLContext.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
- Sound.h
- SoundContext.h
- SDLContext.h
ComponentManager.h
ComponentManager.hpp
Component.h
Collider.h
- SDLContext.h
)
add_subdirectory(api)
-add_subdirectory(util)
+add_subdirectory(facade)
add_subdirectory(system)
+add_subdirectory(util)