aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-31 18:41:30 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-31 18:41:30 +0100
commit8e3367b186e60eb1e33bf58a066823cb00a7566e (patch)
treec4038a31993767276efec5fa1b1a37dff3b79465 /src/crepe/CMakeLists.txt
parentb7df77d6cc26cb9ee46891d7108f01734b3104dd (diff)
parent35ef3ba91ce9e00466508f2388f4c1dd2321b505 (diff)
Merge branch 'master' into poc/audio-miniaudio
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt39
1 files changed, 37 insertions, 2 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 392b7d7..d938eb8 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,3 +1,38 @@
-target_sources(main PUBLIC
- main.cpp
+target_sources(crepe PUBLIC
+ Asset.cpp
+ Sound.cpp
+ SoundContext.cpp
+ Particle.cpp
+ ParticleSystem.cpp
+ SDLApp.cpp
+ ComponentManager.cpp
+ Component.cpp
+ ScriptSystem.cpp
+ PhysicsSystem.cpp
+ CollisionSystem.cpp
+ Collider.cpp
+ SDLContext.cpp
+
+ RenderSystem.cpp
)
+
+target_sources(crepe PUBLIC FILE_SET HEADERS FILES
+ Asset.h
+ Sound.h
+ SoundContext.h
+ SDLContext.h
+ ComponentManager.h
+ ComponentManager.hpp
+ Component.h
+ System.h
+ ScriptSystem.h
+ PhysicsSystem.h
+ CollisionSystem.h
+ Collider.h
+ SDLContext.h
+ RenderSystem.h
+)
+
+add_subdirectory(api)
+add_subdirectory(util)
+