aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-11-28 10:13:11 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-11-28 10:13:11 +0100
commit6fd7cec7d4bbf5aeb361b3f1337671bb0f9af61b (patch)
tree01f6977c66a1e07e07aae42358a7e1a4e55ef53c /src/crepe/CMakeLists.txt
parentd1eed940b8119e95a14f1d08bf26184c7f0a0d8f (diff)
manager mediator refactor
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 7e176e7..da9d492 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -1,13 +1,10 @@
target_sources(crepe PUBLIC
Particle.cpp
- ComponentManager.cpp
Component.cpp
Collider.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
- ComponentManager.h
- ComponentManager.hpp
Component.h
Collider.h
ValueBroker.h
@@ -16,6 +13,7 @@ target_sources(crepe PUBLIC FILE_SET HEADERS FILES
add_subdirectory(api)
add_subdirectory(facade)
+add_subdirectory(manager)
add_subdirectory(system)
add_subdirectory(util)