aboutsummaryrefslogtreecommitdiff
path: root/src/crepe/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-06 13:22:10 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-06 13:22:10 +0200
commit7c9d3452c99fcb89ea6df55755e90f741b23cf10 (patch)
tree93fab445cd4c0ebb392c2f4def2a0bd32d2709d2 /src/crepe/CMakeLists.txt
parent02d658a7ed92bacfdaed587102f0d2e5f6c5dc01 (diff)
copy homemade ECS to crepe + correct code style
Diffstat (limited to 'src/crepe/CMakeLists.txt')
-rw-r--r--src/crepe/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/crepe/CMakeLists.txt b/src/crepe/CMakeLists.txt
index 208ba1f..5840208 100644
--- a/src/crepe/CMakeLists.txt
+++ b/src/crepe/CMakeLists.txt
@@ -2,12 +2,20 @@ target_sources(crepe PUBLIC
Asset.cpp
Sound.cpp
SoundContext.cpp
+ ComponentManager.cpp
+ Components.cpp
+ GameObject.cpp
)
target_sources(crepe PUBLIC FILE_SET HEADERS FILES
Asset.h
Sound.h
SoundContext.h
+ ComponentManager.h
+ ComponentManager.hpp
+ Components.h
+ GameObject.h
+ GameObject.hpp
)
add_subdirectory(api)