aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-22 15:37:00 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-22 15:37:00 +0200
commitf1857fc2d4ddec71b3f0395903f8446cf96b8d0c (patch)
treefeb0a1b4f80cb67ca9af89545ae67a2c03e2f23b /src/CMakeLists.txt
parentb151274f9009eb9f86e4df29ca2c75f5b01d4092 (diff)
fixed everything and can now work with new compiler, example rendering and made it work with component manager
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 09c60bd..8a47905 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,6 +8,7 @@ set(CMAKE_BUILD_TYPE Debug)
project(crepe C CXX)
find_package(SDL2 REQUIRED)
+find_package(SDL2_image REQUIRED)
find_package(SoLoud REQUIRED)
find_package(GTest REQUIRED)
@@ -20,7 +21,8 @@ target_include_directories(crepe
target_link_libraries(crepe
PRIVATE soloud
- PRIVATE SDL2
+ PUBLIC SDL2
+ PUBLIC SDL2_image
)
add_subdirectory(crepe)