aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-01 21:22:30 +0200
committerheavydemon21 <nielsstunnebrink1@gmail.com>2024-10-01 21:22:30 +0200
commite0ea870fdfcfbe9e3f0e47215bb809d4353d88e2 (patch)
tree16f694c46ec4b76019187322da2bdd87906bf5ba /src/CMakeLists.txt
parent7230b630025886939c726e07eba1a0b35511f687 (diff)
removed submodule and updating resource_manager
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cb310af..27e5188 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,6 +9,7 @@ set(CMAKE_BUILD_TYPE Debug)
add_compile_definitions(DEBUG)
add_subdirectory(../lib/soloud soloud)
+add_subdirectory(../lib/SDL_image SDL_image)
project(crepe C CXX)
@@ -21,6 +22,8 @@ target_include_directories(crepe
# TODO: libraries should be linked as PRIVATE
target_link_libraries(crepe
PUBLIC soloud
+ PUBLIC SDL2
+ PUBLIC SDL2_image
)
add_subdirectory(crepe)
@@ -30,5 +33,5 @@ install(
FILE_SET HEADERS DESTINATION include/crepe
)
-add_executable(dummy_rm dummy_resource_manager.cpp)
+add_executable(dummy_rm dummy_audio.cpp)
target_link_libraries(dummy_rm PUBLIC crepe)