aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authormax-001 <maxsmits21@knpmail.nl>2024-10-09 10:54:50 +0200
committermax-001 <maxsmits21@knpmail.nl>2024-10-09 10:54:50 +0200
commitf5b4e2c84326bd96c78ad1f6e4481c1970e54444 (patch)
treeaa75ef01ace01d86ffda93632e0b40dc11e0dcbc /src/CMakeLists.txt
parent765550bce8a81c6f0c79c0083b14ef68e0c900b2 (diff)
parent6b7a670d60fec808e4fd1fcf3a8df2c503dcbdf4 (diff)
Merge remote-tracking branch 'origin/master' into max/POC-ECS-homemade
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt27
1 files changed, 26 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0090188..62ca9a0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,9 +8,34 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
set(CMAKE_BUILD_TYPE Debug)
add_compile_definitions(DEBUG)
+add_subdirectory(../lib/soloud soloud)
+add_subdirectory(../lib/googletest googletest)
+
project(crepe C CXX)
-add_executable(main)
+add_library(crepe SHARED)
+add_executable(test_main EXCLUDE_FROM_ALL)
+
+target_include_directories(crepe
+ PUBLIC SYSTEM INTERFACE .
+)
+
+# TODO: libraries should be linked as PRIVATE
+target_link_libraries(crepe
+ PUBLIC soloud
+)
add_subdirectory(crepe)
+add_subdirectory(test)
+add_subdirectory(example)
+
+install(
+ TARGETS crepe
+ FILE_SET HEADERS DESTINATION include/crepe
+)
+
+target_link_libraries(test_main
+ PRIVATE gtest_main
+ PUBLIC crepe
+)