aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-09-25 17:36:31 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-09-25 17:36:31 +0200
commitf3eeedc91a04ca0651e0fe78a2119e7e3e38e391 (patch)
treefc2265ccc90abcefbdf2eb7670eb2c30c56da300 /src/CMakeLists.txt
parentf4560e02f703f1c6f857c8e5af63fa9fc4ca6438 (diff)
WIP Audio API + facade
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0090188..cc71435 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,9 +8,20 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
set(CMAKE_BUILD_TYPE Debug)
add_compile_definitions(DEBUG)
+add_subdirectory(../lib/soloud soloud)
+
project(crepe C CXX)
-add_executable(main)
+add_library(crepe SHARED)
+
+target_include_directories(crepe
+ SYSTEM INTERFACE .
+)
+
+# NOTE: all libraries *must* be linked as PRIVATE
+target_link_libraries(crepe
+ PRIVATE soloud
+)
add_subdirectory(crepe)