aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-09-03 19:34:59 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-09-03 19:36:52 +0200
commitc818aa8a02d2809b3189a1fdbec580fd59d22ce2 (patch)
treeab37a6959f7e63ce8ef70a338bef20a4ac6dbd3f /src/CMakeLists.txt
parent387c97bae8fd2e21dcd5b0a2b938d23e5d007a0d (diff)
shuffle files
Moving all code into src/crepe allows you to add the src folder as SYSTEM INTERFACE, resulting in includes that look like `<crepe/xyz.h>`.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..3ade1e3
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.28)
+
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+
+# enable debug features
+set(CMAKE_BUILD_TYPE Debug)
+add_compile_definitions(DEBUG)
+
+project(crepe C CXX)
+
+add_executable(main)
+
+add_subdirectory(crepe)
+