aboutsummaryrefslogtreecommitdiff
path: root/mwe/gameloop/CMakeLists.txt
diff options
context:
space:
mode:
authorWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-09-27 14:00:57 +0200
committerWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-09-27 14:00:57 +0200
commita78f7bbfcdabad9550afe22f615b973b92cb074f (patch)
tree318e888219965634e3b81be9b74a0522af2136e0 /mwe/gameloop/CMakeLists.txt
parent86a7bd1aee2ee96079e00e2696a624fd6b642fa0 (diff)
parentf4560e02f703f1c6f857c8e5af63fa9fc4ca6438 (diff)
fixed merge conflict
Diffstat (limited to 'mwe/gameloop/CMakeLists.txt')
-rw-r--r--mwe/gameloop/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/mwe/gameloop/CMakeLists.txt b/mwe/gameloop/CMakeLists.txt
new file mode 100644
index 0000000..233ba98
--- /dev/null
+++ b/mwe/gameloop/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 3.5)
+project(gameloop)
+
+# Set the C++ standard (optional, but good practice)
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD_REQUIRED True)
+
+# Find the SDL2 package
+find_package(SDL2 REQUIRED)
+
+add_executable(gameloop
+ src/loopManager.cpp
+ src/window.cpp
+ src/main.cpp
+ src/eventManager.cpp
+ src/gameObject.cpp
+ src/timer.cpp
+)
+
+# Link the SDL2 library to your project
+target_link_libraries(gameloop ${SDL2_LIBRARIES})
+
+# Include SDL2 header files and project headers
+target_include_directories(gameloop PRIVATE ${SDL2_INCLUDE_DIRS})
+target_include_directories(gameloop PRIVATE ${CMAKE_SOURCE_DIR}/include)
+