aboutsummaryrefslogtreecommitdiff
path: root/mwe/events/CMakeLists.txt
diff options
context:
space:
mode:
authorWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-10-28 11:06:21 +0100
committerWBoerenkamps <wrj.boerenkamps@student.avans.nl>2024-10-28 11:06:21 +0100
commit29f9a26046e35c7eb0157df92757ce8e39f1ec74 (patch)
tree18be4912561c2fcc9a57b99466c74977e11f2abf /mwe/events/CMakeLists.txt
parentf1b2c5a38f49bb319babf11bf64c420a63e104f2 (diff)
iMouseListener and iKeyListener implementation
Diffstat (limited to 'mwe/events/CMakeLists.txt')
-rw-r--r--mwe/events/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/mwe/events/CMakeLists.txt b/mwe/events/CMakeLists.txt
index 585d869..e429516 100644
--- a/mwe/events/CMakeLists.txt
+++ b/mwe/events/CMakeLists.txt
@@ -21,7 +21,7 @@ add_executable(gameloop
src/keyCodes.cpp
src/eventHandler.cpp
)
-
+add_subdirectory(../../lib/SDL_ttf SDL_ttf)
# Link the SDL2 library to your project
target_link_libraries(gameloop ${SDL2_LIBRARIES})
@@ -29,3 +29,4 @@ target_link_libraries(gameloop ${SDL2_LIBRARIES})
target_include_directories(gameloop PRIVATE ${SDL2_INCLUDE_DIRS})
target_include_directories(gameloop PRIVATE ${CMAKE_SOURCE_DIR}/include)
+file(COPY ${PROJECT_SOURCE_DIR}/font DESTINATION ${CMAKE_BINARY_DIR})