aboutsummaryrefslogtreecommitdiff
path: root/mwe/events/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-11-04 08:31:05 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-11-04 08:31:05 +0100
commit63d50eea4e389e73e26f41452829dd48e6190c70 (patch)
tree82a8ef7a28fe7e069dbe9830adc28fd49dd85846 /mwe/events/CMakeLists.txt
parent06f65659fc6ffde7cabd2135040cbfbf089e5a24 (diff)
parent2585dc3cab48ccad0cfa0c63354662d656c86c46 (diff)
Merge branch 'master' of github.com:lonkaars/crepe
Diffstat (limited to 'mwe/events/CMakeLists.txt')
-rw-r--r--mwe/events/CMakeLists.txt33
1 files changed, 21 insertions, 12 deletions
diff --git a/mwe/events/CMakeLists.txt b/mwe/events/CMakeLists.txt
index 585d869..12e45a7 100644
--- a/mwe/events/CMakeLists.txt
+++ b/mwe/events/CMakeLists.txt
@@ -2,30 +2,39 @@ cmake_minimum_required(VERSION 3.5)
project(gameloop)
# Set the C++ standard (optional, but good practice)
-set(CMAKE_C_STANDARD 11)
+set(CMAKE_C_STANDARD 17)
set(CMAKE_CXX_STANDARD 20)
set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
set(CMAKE_BUILD_TYPE Debug)
# Find the SDL2 package
find_package(SDL2 REQUIRED)
+# Find the SDL2_ttf package
+find_package(SDL2_ttf REQUIRED)
add_executable(gameloop
- src/window.cpp
- src/main.cpp
- #src/eventHandler.cpp
- src/eventManager.cpp
- src/event.cpp
- src/loopManager.cpp
- src/timer.cpp
- src/keyCodes.cpp
- src/eventHandler.cpp
+ src/window.cpp
+ src/main.cpp
+ src/eventManager.cpp
+ src/event.cpp
+ src/loopManager.cpp
+ src/timer.cpp
+ src/keyCodes.cpp
+ src/eventHandler.cpp
+ src/iMouseListener.cpp
+ src/iKeyListener.cpp
+ src/mouseListenerTest.cpp
+ src/keyListenerTest.cpp
+ src/inputSystem.cpp
+ src/uiRenderer.cpp
+ src/uiObject.cpp
)
-# Link the SDL2 library to your project
-target_link_libraries(gameloop ${SDL2_LIBRARIES})
+target_link_libraries(gameloop ${SDL2_LIBRARIES} SDL2_ttf::SDL2_ttf)
# Include SDL2 header files and project headers
target_include_directories(gameloop PRIVATE ${SDL2_INCLUDE_DIRS})
target_include_directories(gameloop PRIVATE ${CMAKE_SOURCE_DIR}/include)
+# Copy font files to the build directory
+file(COPY ${PROJECT_SOURCE_DIR}/font DESTINATION ${CMAKE_BINARY_DIR})