aboutsummaryrefslogtreecommitdiff
path: root/mwe/ecs-memory-efficient/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-10-17 17:07:55 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-10-17 17:07:55 +0200
commite0fab8139a4dd8a33e54cb7fdea85d2bd3feaeb9 (patch)
treed7cc1a2583899d4557e54a2b33dee342f0405a2e /mwe/ecs-memory-efficient/CMakeLists.txt
parentd21afe5b33b4cb3f5cf1917f4d15f402de41a032 (diff)
parentd9889e4501c1f3ebd649b81816e80d1b40d14c87 (diff)
Merge branch 'max/POC-ECS-memory-efficient' of github.com:lonkaars/crepe
Diffstat (limited to 'mwe/ecs-memory-efficient/CMakeLists.txt')
-rw-r--r--mwe/ecs-memory-efficient/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/mwe/ecs-memory-efficient/CMakeLists.txt b/mwe/ecs-memory-efficient/CMakeLists.txt
new file mode 100644
index 0000000..d072907
--- /dev/null
+++ b/mwe/ecs-memory-efficient/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.5)
+project(ecs-memory-efficient)
+
+# Set the C++ standard (optional, but good practice)
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED True)
+
+# Use the debug mode (otherwise breakpoints are not compiled)
+set(CMAKE_BUILD_TYPE Debug)
+
+add_executable(ecs-memory-efficient
+ src/main.cpp
+ src/ComponentManager.cpp
+ src/Components.cpp
+ src/GameObjectMax.cpp
+)
+target_include_directories(ecs-memory-efficient PRIVATE "${CMAKE_SOURCE_DIR}/inc")