aboutsummaryrefslogtreecommitdiff
path: root/mwe/ecs-memory-efficient/CMakeLists.txt
diff options
context:
space:
mode:
authorjaroWMR <jarorutjes07@gmail.com>2024-10-20 13:07:02 +0200
committerjaroWMR <jarorutjes07@gmail.com>2024-10-20 13:07:02 +0200
commit4ff1159fe5f6ee6dd8becc662bc95a93acda545a (patch)
tree670caa42ad4ffbf007a6d7cba683f4f84af87592 /mwe/ecs-memory-efficient/CMakeLists.txt
parent0f03cdbf23f57116b7664a7c98c4605fd69bb961 (diff)
parent77555730e3ddb811b9ce8470659663e3f1573de2 (diff)
Merge branch 'master' of github.com:lonkaars/crepe into jaro/poc-physics
Diffstat (limited to 'mwe/ecs-memory-efficient/CMakeLists.txt')
-rw-r--r--mwe/ecs-memory-efficient/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/mwe/ecs-memory-efficient/CMakeLists.txt b/mwe/ecs-memory-efficient/CMakeLists.txt
new file mode 100644
index 0000000..d072907
--- /dev/null
+++ b/mwe/ecs-memory-efficient/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.5)
+project(ecs-memory-efficient)
+
+# Set the C++ standard (optional, but good practice)
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED True)
+
+# Use the debug mode (otherwise breakpoints are not compiled)
+set(CMAKE_BUILD_TYPE Debug)
+
+add_executable(ecs-memory-efficient
+ src/main.cpp
+ src/ComponentManager.cpp
+ src/Components.cpp
+ src/GameObjectMax.cpp
+)
+target_include_directories(ecs-memory-efficient PRIVATE "${CMAKE_SOURCE_DIR}/inc")