aboutsummaryrefslogtreecommitdiff
path: root/mwe/ecs-homemade/CMakeLists.txt
diff options
context:
space:
mode:
authorMax-001 <80035972+Max-001@users.noreply.github.com>2024-10-02 15:26:24 +0200
committerMax-001 <80035972+Max-001@users.noreply.github.com>2024-10-02 15:26:24 +0200
commit2bd37e7d98728d72ba44da18eefea91547a7885a (patch)
tree63ebde9c853c5f683e50ffc4dd8950b08dc48efa /mwe/ecs-homemade/CMakeLists.txt
parente409986d9a21ca96ee0b491826eb0008ff6ab8e0 (diff)
Refactored componentManager (it now uses smart pointer, does not return raw pointers (it only returns references) and it is now possible to store multiple components of the same type for the same entity)
Diffstat (limited to 'mwe/ecs-homemade/CMakeLists.txt')
-rw-r--r--mwe/ecs-homemade/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/mwe/ecs-homemade/CMakeLists.txt b/mwe/ecs-homemade/CMakeLists.txt
index 2819727..6267c1a 100644
--- a/mwe/ecs-homemade/CMakeLists.txt
+++ b/mwe/ecs-homemade/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.5)
project(ecs-homemade)
# Set the C++ standard (optional, but good practice)
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED True)
# Use the debug mode (otherwise breakpoints are not compiled)