aboutsummaryrefslogtreecommitdiff
path: root/mwe/ecs-homemade/CMakeLists.txt
diff options
context:
space:
mode:
authorMax-001 <80035972+Max-001@users.noreply.github.com>2024-09-25 21:08:54 +0200
committerMax-001 <80035972+Max-001@users.noreply.github.com>2024-09-25 21:08:54 +0200
commit5458abaca5f01a4d34bb55b1b44dc4fb4e9890be (patch)
treea23e35dc95c69aced7d4e16550a2b4fff8507a6c /mwe/ecs-homemade/CMakeLists.txt
parent918392ec503a66e369fffa3a5a49c8afccf96a62 (diff)
Made a homemade ECS
Diffstat (limited to 'mwe/ecs-homemade/CMakeLists.txt')
-rw-r--r--mwe/ecs-homemade/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/mwe/ecs-homemade/CMakeLists.txt b/mwe/ecs-homemade/CMakeLists.txt
index 26bf600..5960181 100644
--- a/mwe/ecs-homemade/CMakeLists.txt
+++ b/mwe/ecs-homemade/CMakeLists.txt
@@ -2,9 +2,13 @@ cmake_minimum_required(VERSION 3.5)
project(ecs-homemake)
# Set the C++ standard (optional, but good practice)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED True)
add_executable(ecs-homemake
src/main.cpp
+ src/ComponentManager.cpp
+ src/Components.cpp
+ src/GameObjectMax.cpp
)
+target_include_directories(ecs-homemake PRIVATE "${CMAKE_SOURCE_DIR}/inc")