aboutsummaryrefslogtreecommitdiff
path: root/gameloop/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-09-21 15:31:58 +0200
committerLoek Le Blansch <loek@pipeframe.xyz>2024-09-21 15:31:58 +0200
commitca393b6b47618e48c107ad5c021d86700343648e (patch)
tree298bff793ee331566b6be1840c8d7404409b5198 /gameloop/CMakeLists.txt
parent8bf919f750807060f3ac2c640b8a02300af1733c (diff)
move gameloop poc to mwe
Diffstat (limited to 'gameloop/CMakeLists.txt')
-rw-r--r--gameloop/CMakeLists.txt28
1 files changed, 0 insertions, 28 deletions
diff --git a/gameloop/CMakeLists.txt b/gameloop/CMakeLists.txt
deleted file mode 100644
index 6bc5017..0000000
--- a/gameloop/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-cmake_minimum_required(VERSION 3.5)
-project(gameloop)
-
-# Set the C++ standard (optional, but good practice)
-set(CMAKE_CXX_STANDARD 11)
-set(CMAKE_CXX_STANDARD_REQUIRED True)
-
-# Find the SDL2 package
-find_package(SDL2 REQUIRED)
-
-# Add your executable
-set(SOURCES
- src/loopManager
- src/window.cpp
- src/main.cpp
- src/eventManager.cpp
- src/gameObject.cpp
- src/timer.cpp
-)
-
-add_executable(gameloop ${SOURCES})
-
-# Link the SDL2 library to your project
-target_link_libraries(gameloop ${SDL2_LIBRARIES})
-
-# Include SDL2 header files and project headers
-target_include_directories(gameloop PRIVATE ${SDL2_INCLUDE_DIRS})
-target_include_directories(gameloop PRIVATE ${CMAKE_SOURCE_DIR}/include)