aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
authorJAROWMR <jarorutjes07@gmail.com>2024-12-28 16:22:58 +0100
committerJAROWMR <jarorutjes07@gmail.com>2024-12-28 16:22:58 +0100
commit26d66b7a73ac8d172d342be03bd75bd5bea221e1 (patch)
tree8814afa7859bf7d142b475acec4432e254e204c8 /game/CMakeLists.txt
parent6a3063e6012bae44457b668ce48c48b8af90a95d (diff)
coin system
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index 60ac8e6..6f3beb5 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -31,6 +31,9 @@ set(SOURCES
mainmenu/ShopMenuScene.cpp
mainmenu/BannerSubScene.cpp
mainmenu/ButtonSetShopScript.cpp
+ coins/CoinSubScene.cpp
+ coins/CoinSystem.cpp
+ coins/CoinSystemScript.cpp
)
set(HEADERS
@@ -55,6 +58,10 @@ set(HEADERS
mainmenu/ShopMenuScene.h
mainmenu/BannerSubScene.h
mainmenu/ButtonSetShopScript.h
+ coins/CoinData.h
+ coins/CoinSubScene.h
+ coins/CoinSystem.h
+ coins/CoinSystemScript.h
)
add_executable(main ${SOURCES} ${HEADERS})