aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
authorheavydemon21 <nielsstunnebrink1@gmail.com>2025-01-08 14:51:10 +0100
committerheavydemon21 <nielsstunnebrink1@gmail.com>2025-01-08 14:51:10 +0100
commitd989c1c51bf4d4fbb301493e73bc77e1873143b2 (patch)
tree758363b217350ae32ce1beeee7d4a4014817a37e /game/CMakeLists.txt
parent18a8813645187102fc6261b8d5be1a41c8f0dae4 (diff)
working zapper, missilies with scheduler
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index dec161d..d1f49ed 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -10,7 +10,7 @@ add_subdirectory(../src crepe)
add_executable(main)
-add_executable(main PUBLIC
+target_sources(main PUBLIC
#background
background/AquariumSubScene.cpp
background/AquariumScript.cpp
@@ -43,13 +43,8 @@ add_executable(main PUBLIC
preview/NpcScript.cpp
preview/PrevPlayerSubScene.cpp
preview/PrevPlayerScript.cpp
- main.cpp
# scripts
-
-add_executable(main)
-
-target_sources(main PUBLIC
GameScene.cpp
MoveCameraManualyScript.cpp
StartGameScript.cpp