aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
authorJAROWMR <jarorutjes07@gmail.com>2024-12-23 21:17:45 +0100
committerJAROWMR <jarorutjes07@gmail.com>2024-12-23 21:17:45 +0100
commit225e873c8ac9c4c08720a69b8f2c817d22cf0071 (patch)
tree20c1539a7ea7d133fca143e922165fd7533c87fe /game/CMakeLists.txt
parenta3097a20daaf58e4e3852bfb36315dc5e14d3e52 (diff)
made script reusable to switch scenes
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index 5365fb4..4776d03 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -25,7 +25,9 @@ set(SOURCES
mainmenu/ButtonScript.cpp
mainmenu/ButtonSubScene.cpp
mainmenu/MainMenuScene.cpp
- mainmenu/ButtonStartScript.cpp
+ mainmenu/ShowScript.cpp
+ mainmenu/ShowStartScript.cpp
+ mainmenu/ShowPreviewScript.cpp
)
set(HEADERS
@@ -44,7 +46,9 @@ set(HEADERS
mainmenu/ButtonSubScene.h
mainmenu/MainMenuScene.h
mainmenu/MainMenuConfig.h
- mainmenu/ButtonStartScript.h
+ mainmenu/ShowScript.h
+ mainmenu/ShowStartScript.h
+ mainmenu/ShowPreviewScript.h
)
add_executable(main ${SOURCES} ${HEADERS})