aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
authorLoek Le Blansch <loek@pipeframe.xyz>2024-12-22 16:12:31 +0100
committerLoek Le Blansch <loek@pipeframe.xyz>2024-12-22 16:12:31 +0100
commit7e12ebdf945d40d6f11872cf5852c9bb54d1864f (patch)
treed81f4661e2fd47f487cf0c9627baa1e21dc45b37 /game/CMakeLists.txt
parent61148c757a1f742ff09e40e5347e74e638c7371c (diff)
big WIP
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index 937b5e6..a149487 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -8,20 +8,19 @@ set(CMAKE_BUILD_TYPE Debug)
project(game C CXX)
add_subdirectory(../src crepe)
-add_executable(main
- background/AquariumSubScene.cpp
- background/BackgroundSubScene.cpp
- background/ForestParallaxScript.cpp
- background/ForestSubScene.cpp
+
+add_executable(main)
+
+target_sources(main PUBLIC
GameScene.cpp
- background/HallwaySubScene.cpp
MoveCameraManualyScript.cpp
- PlayerScript.cpp
- PlayerSubScene.cpp
StartGameScript.cpp
- background/StartSubScene.cpp
main.cpp
)
+add_subdirectory(background)
+add_subdirectory(prefab)
+
target_link_libraries(main PUBLIC crepe)
+target_include_directories(main PRIVATE .)