aboutsummaryrefslogtreecommitdiff
path: root/game/CMakeLists.txt
diff options
context:
space:
mode:
authorJAROWMR <jarorutjes07@gmail.com>2024-12-28 12:15:39 +0100
committerJAROWMR <jarorutjes07@gmail.com>2024-12-28 12:15:39 +0100
commitdeb1cd4732fb3a880cd10ce677e62fc2aac974a0 (patch)
tree28f02f1f4d88687688e9670c85f409c90bfc041d /game/CMakeLists.txt
parentf91eff6285f651f5c3e310927026f419e67657ab (diff)
interface scripts added
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r--game/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt
index d33290e..2fc5e41 100644
--- a/game/CMakeLists.txt
+++ b/game/CMakeLists.txt
@@ -22,14 +22,15 @@ set(SOURCES
StartGameScript.cpp
StartSubScene.cpp
main.cpp
- mainmenu/ButtonScript.cpp
+ mainmenu/IButtonScript.cpp
mainmenu/ButtonSubScene.cpp
mainmenu/MainMenuScene.cpp
- mainmenu/ShowScript.cpp
+ mainmenu/IShowScript.cpp
mainmenu/ShowStartScript.cpp
mainmenu/ShowPreviewScript.cpp
mainmenu/ShopMenuScene.cpp
mainmenu/BannerSubScene.cpp
+ mainmenu/SetShopScript.cpp
)
set(HEADERS
@@ -44,15 +45,16 @@ set(HEADERS
PlayerSubScene.h
StartGameScript.h
StartSubScene.h
- mainmenu/ButtonScript.h
+ mainmenu/IButtonScript.h
mainmenu/ButtonSubScene.h
mainmenu/MainMenuScene.h
mainmenu/MainMenuConfig.h
- mainmenu/ShowScript.h
+ mainmenu/IShowScript.h
mainmenu/ShowStartScript.h
mainmenu/ShowPreviewScript.h
mainmenu/ShopMenuScene.h
mainmenu/BannerSubScene.h
+ mainmenu/SetShopScript.h
)
add_executable(main ${SOURCES} ${HEADERS})