aboutsummaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index bcef4c0..35a55b6 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -8,13 +8,18 @@ project(puzzlebox_client C CXX)
include(../proto/include.cmake)
-add_executable(main
+add_executable(pbc
main.cpp
+ rl.cpp
+ sock.cpp
+ cmd.cpp
+ parse.cpp
)
-target_link_libraries(main
+target_link_libraries(pbc
puzbus
mpack
+ readline # this is such a common library that I did not bother adding it as a submodule
)