aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorThomasAvans <tv.intanker@student.avans.nl>2024-04-10 16:42:55 +0200
committerThomasAvans <tv.intanker@student.avans.nl>2024-04-10 16:42:55 +0200
commit4f88b6ba253ddb34fdc5049ab3044516df73257c (patch)
tree77986353c7ee182405fd0bd978f23022c9f90fc8 /test/CMakeLists.txt
parent4b405fe0f6dbf6c6e377c1b04f20be27d7b7a761 (diff)
Setup the googletest testing framework
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..a0bd099
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required(VERSION 3.29)
+
+project(puzzlebox_test C CXX ASM)
+
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+
+add_executable(tests
+ ExampleTest.cpp
+)
+
+enable_testing()
+
+add_subdirectory(lib/googletest)
+
+target_include_directories(tests PRIVATE ${CMAKE_CURRENT_LIST_DIR})
+target_link_libraries(tests PRIVATE gtest_main)
+
+add_test(
+ NAME tests
+ COMMAND tests
+) \ No newline at end of file