aboutsummaryrefslogtreecommitdiff
path: root/main/puzzle/software/CMakeLists.txt
diff options
context:
space:
mode:
authorThomasAvans <tv.intanker@student.avans.nl>2024-05-11 15:10:16 +0200
committerThomasAvans <tv.intanker@student.avans.nl>2024-05-11 15:10:16 +0200
commit763dd510df1245656f9ee0799c95cc84fc704120 (patch)
tree327ace7d50782043f56bf0811cfa188ca3222851 /main/puzzle/software/CMakeLists.txt
parent488899377dc72989a178173662f95d25fc69c59f (diff)
Added template ESP-IDF project
Diffstat (limited to 'main/puzzle/software/CMakeLists.txt')
-rw-r--r--main/puzzle/software/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/puzzle/software/CMakeLists.txt b/main/puzzle/software/CMakeLists.txt
new file mode 100644
index 0000000..e0bd7b6
--- /dev/null
+++ b/main/puzzle/software/CMakeLists.txt
@@ -0,0 +1,8 @@
+# For more information about build system see
+# https://docs.espressif.com/projects/esp-idf/en/latest/api-guides/build-system.html
+# The following five lines of boilerplate have to be in your project's
+# CMakeLists in this exact order for cmake to work correctly
+cmake_minimum_required(VERSION 3.5)
+
+include($ENV{IDF_PATH}/tools/cmake/project.cmake)
+project(software) \ No newline at end of file