aboutsummaryrefslogtreecommitdiff
path: root/main/puzzle/neo/esp-neopuzzle/CMakeLists.txt
diff options
context:
space:
mode:
authorElwin Hammer <elwinhamer@gmail.com>2024-04-23 11:49:54 +0200
committerElwin Hammer <elwinhamer@gmail.com>2024-04-23 11:49:54 +0200
commit65f139edb2d3cfa055504e04cba266566fdfbf3b (patch)
treed0c19ceec58bb1df5ee03aa09b861b2bbbe5df31 /main/puzzle/neo/esp-neopuzzle/CMakeLists.txt
parent7b8d066223b9af513193020423b86c9f52234001 (diff)
ESP version of the neotrellis puzzle (first setup)
Diffstat (limited to 'main/puzzle/neo/esp-neopuzzle/CMakeLists.txt')
-rw-r--r--main/puzzle/neo/esp-neopuzzle/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/puzzle/neo/esp-neopuzzle/CMakeLists.txt b/main/puzzle/neo/esp-neopuzzle/CMakeLists.txt
new file mode 100644
index 0000000..fb90ef1
--- /dev/null
+++ b/main/puzzle/neo/esp-neopuzzle/CMakeLists.txt
@@ -0,0 +1,8 @@
+# For more information about build system see
+# https://docs.espressif.com/projects/esp-idf/en/latest/api-guides/build-system.html
+# The following five lines of boilerplate have to be in your project's
+# CMakeLists in this exact order for cmake to work correctly
+cmake_minimum_required(VERSION 3.16)
+
+include($ENV{IDF_PATH}/tools/cmake/project.cmake)
+project(esp-neopuzzle)