aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorDarius Jahandarie <djahandarie@gmail.com>2023-03-12 20:31:26 +0900
committerGitHub <noreply@github.com>2023-03-12 20:31:26 +0900
commit75fd35e2ab183278253248fd06e9d870ce21777a (patch)
tree0dbd61ecb29f713ab660c3fd2cbcd298e3af010f /shell.nix
parentf73611de12c0fb6ccf9e361e48abd7de6e63b4e8 (diff)
parent42449228f00d688dbbc7b1c30900257b43780a2f (diff)
Merge pull request #88 from themoeway/nix-support
Make it easy to build project on Nix package manager / NixOS
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..9001ef77
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,4 @@
+{ pkgs ? import <nixpkgs> { } }:
+pkgs.mkShell {
+ nativeBuildInputs = [ pkgs.nodejs ];
+}