From b341514a221c49b0b444b6185947e4a4c00e9aeb Mon Sep 17 00:00:00 2001
From: Nadia Holmquist Pedersen <nadia@nhp.sh>
Date: Sun, 10 May 2020 23:45:59 +0200
Subject: Use -Og for debug builds

---
 CMakeLists.txt | 4 ++++
 1 file changed, 4 insertions(+)

(limited to 'CMakeLists.txt')

diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa33d4b..0aa558d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,10 @@ else()
 	option(ENABLE_LTO "Enable link-time optimization" OFF)
 endif()
 
+if (CMAKE_BUILD_TYPE STREQUAL Debug)
+	add_compile_options(-Og)
+endif()
+
 if(ENABLE_LTO)
 	add_compile_options(-O3 -flto)
 	add_link_options(-flto)
-- 
cgit v1.2.3